Update SAMl plugin to use current Spring Security release

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Update SAMl plugin to use current Spring Security release

kuisathaverat
Hi,

Due to Upgrade Acegi Security to the latest Spring Security release(https://issues.jenkins.io/browse/JENKINS-5303),
I updated the SAML plugin to use the new Sprint Security version and pac4j 3.9.0(https://issues.jenkins.io/browse/JENKINS-63350 and https://github.com/jenkinsci/saml-plugin/pull/90) ,
this requires bumping the shibboleth library. Shibboleth library is not in the maven central repository
because of that, I have open an issue to mirror/copy the Shibboleth library repository (https://issues.jenkins.io/browse/INFRA-2809)
The issue here is that I cannot merge and release the SAML plugin with that change without resolve INFRA-2809
in one way or another, Could we find a solution for this?


--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/CAKo5QroM6ixkFUpPFMeJ0xNyhcrr%3DP4bNN8%2BBSyvk%3DEp%2BS5etg%40mail.gmail.com.