auto build of downstream project not working

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

auto build of downstream project not working

Johannes Eickhold
Hi, maybe this is a bug in 1.104?

I configured two projects A and B in Hudson with A having "Post-build
Actions"->"Build other projects" checked and "Projects to build" ponting
to B. The project page of A is correctly showing B under "Downstream
Projects" and B has A as its upstream.

Unfortunately B is not building after A was build.

Greets,
  Johannes.

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: auto build of downstream project not working

Johannes Eickhold
On Sun, 2007-04-29 at 16:45 +0200, Johannes Eickhold wrote:
> I configured two projects A and B in Hudson with A having "Post-build
> Actions"->"Build other projects" checked and "Projects to build" ponting
> to B. The project page of A is correctly showing B under "Downstream
> Projects" and B has A as its upstream.
>
> Unfortunately B is not building after A was build.

Ok - I've got it. A downstream projects gets only build when the
upstream project build was successful. In my case project A was
unstable.

Could I have found this out in advance by reading some documentation?

Could Hudson make this behavior configurable? (i.e. build downstream
projects also if upstream is unstable)

Greets,
  Johannes.

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: auto build of downstream project not working

Kohsuke Kawaguchi
Administrator
Johannes Eickhold wrote:
> Ok - I've got it. A downstream projects gets only build when the
> upstream project build was successful. In my case project A was
> unstable.
>
> Could I have found this out in advance by reading some documentation?
>
> Could Hudson make this behavior configurable? (i.e. build downstream
> projects also if upstream is unstable)

Sorry that it wasted your time. We should have the (?) icon on this,
too. Moving the one-line description to the help section should also
create space for the checkbox to make it configurable.

Could you file this as an issue so that we can keep track?

--
Kohsuke Kawaguchi
Sun Microsystems                   [hidden email]

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: auto build of downstream project not working

Kohsuke Kawaguchi
Administrator
Kohsuke Kawaguchi wrote:
> Could you file this as an issue so that we can keep track?

Scratch that. I just committed this change for the next 1.106.

--
Kohsuke Kawaguchi
Sun Microsystems                   [hidden email]

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: auto build of downstream project not working

Johannes Eickhold
On Sun, 2007-04-29 at 16:58 -0700, Kohsuke Kawaguchi wrote:
> Kohsuke Kawaguchi wrote:
> > Could you file this as an issue so that we can keep track?
>
> Scratch that. I just committed this change for the next 1.106.

Sorry :-) already done. Thanks!

Johannes

signature.asc (196 bytes) Download Attachment