emma plugin icons

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

emma plugin icons

Arnaud LACOUR
Hi all,
  I just tried out 1.121 and installed the emma plugin and even though
it seems to point to the right location
/images/16x16/health-80plus.gif for example it is not rendered (I'm on
vista, I don't really know if it makes any difference)

just thought I'd mention it because this plugin is real neat but that
just looks bad.

cheers,
-=arnaud=-

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

hudson-emma-icons.png (16K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: emma plugin icons

Stephen Connolly-2
Yeah I noticed that bug and i'm tryingto fix it for both emma and clover...

It's the wrong path, as for example, I have hudson at
http://somehost/hudson
And the url for the images is http://somehost/images and not http://somehost/hudson/images

I did not notice this when testing with winstone as it hosts hudson as the root webapp

Arnaud LACOUR wrote
Hi all,
  I just tried out 1.121 and installed the emma plugin and even though
it seems to point to the right location
/images/16x16/health-80plus.gif for example it is not rendered (I'm on
vista, I don't really know if it makes any difference)

just thought I'd mention it because this plugin is real neat but that
just looks bad.

cheers,
-=arnaud=-

 
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@hudson.dev.java.net
For additional commands, e-mail: users-help@hudson.dev.java.net
Reply | Threaded
Open this post in threaded view
|

Re: emma plugin icons

Stephen Connolly-2
Stephen Connolly wrote
Yeah I noticed that bug and i'm trying to fix it for both emma and clover...
I think I have this fixed now.

Just waiting for the latest CVS update of hudson to compile so I can test it.

I will promote the fixes once I have confirmed that they work.

Expect to see them in the next hour or two

-Stephen Connolly
Reply | Threaded
Open this post in threaded view
|

Re: emma plugin icons

Stephen Connolly-2

Stephen Connolly wrote
Stephen Connolly wrote
Yeah I noticed that bug and i'm trying to fix it for both emma and clover...
I think I have this fixed now.

Just waiting for the latest CVS update of hudson to compile so I can test it.

I will promote the fixes once I have confirmed that they work.

Expect to see them in the next hour or two

-Stephen Connolly
emma-1.8 and clover-1.4 have this fix included
Reply | Threaded
Open this post in threaded view
|

Re: emma plugin icons

Kohsuke Kawaguchi
Administrator
Hi,

Or is this a regression in Hudson 1.121? I changed one code related to
path computation, so this is possible.

2007/7/24, Stephen Connolly <[hidden email]>:

>
>
>
> Stephen Connolly wrote:
> >
> >
> > Stephen Connolly wrote:
> >>
> >> Yeah I noticed that bug and i'm trying to fix it for both emma and
> >> clover...
> >>
> > I think I have this fixed now.
> >
> > Just waiting for the latest CVS update of hudson to compile so I can test
> > it.
> >
> > I will promote the fixes once I have confirmed that they work.
> >
> > Expect to see them in the next hour or two
> >
> > -Stephen Connolly
> >
> emma-1.8 and clover-1.4 have this fix included
> --
> View this message in context: http://www.nabble.com/emma-plugin-icons-tf4135060.html#a11763452
> Sent from the Hudson users mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Kohsuke Kawaguchi

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: emma plugin icons

Stephen Connolly-2
kohsuke wrote
Or is this a regression in Hudson 1.121? I changed one code related to
path computation, so this is possible.
Nope! This was a "my bad"

It was not working since I introduced those icons.  I had img src="/images..." which should have been img src="${rootUrl}/images..."

Reply | Threaded
Open this post in threaded view
|

Re: emma plugin icons

Kohsuke Kawaguchi
Administrator
Stephen Connolly wrote:

>
> kohsuke wrote:
>>
>> Or is this a regression in Hudson 1.121? I changed one code related to
>> path computation, so this is possible.
>>
> Nope! This was a "my bad"
>
> It was not working since I introduced those icons.  I had img
> src="/images..." which should have been img src="${rootUrl}/images..."
OK, thanks. Just checking to make sure.

--
Kohsuke Kawaguchi
Sun Microsystems                   [hidden email]

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: emma plugin icons

Arnaud LACOUR
smashing.
That was a quick fix.

I have another request but I will file it if you find it easier to
keep track of tasks.
I have problems since this morning with the emma plugin, it is not
generating the trend graph at all and there's not much output to help
in that department in the console output, could there be a debug
checkbox on the plugin config page to allow easier investigation on
live systems when sh17 hits the fan ?

This shouldn't be emma specific as all plugins could benefit from that
but right now that's what brought the thought in mind.

it's not always convenient to bring the container console or the IDE
debugger so that could help in like 90% of the cases.

just my 2 cents,
Arnaud

On 7/24/07, Kohsuke Kawaguchi <[hidden email]> wrote:

> Stephen Connolly wrote:
> >
> > kohsuke wrote:
> >>
> >> Or is this a regression in Hudson 1.121? I changed one code related to
> >> path computation, so this is possible.
> >>
> > Nope! This was a "my bad"
> >
> > It was not working since I introduced those icons.  I had img
> > src="/images..." which should have been img src="${rootUrl}/images..."
>
> OK, thanks. Just checking to make sure.
>
> --
> Kohsuke Kawaguchi
> Sun Microsystems                   [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: emma plugin icons

Arnaud LACOUR
In reply to this post by Stephen Connolly-2
wait a minute, why do I get the icons alright on a linux browser then ?

On 7/24/07, Stephen Connolly <[hidden email]> wrote:

>
>
> kohsuke wrote:
> >
> > Or is this a regression in Hudson 1.121? I changed one code related to
> > path computation, so this is possible.
> >
> Nope! This was a "my bad"
>
> It was not working since I introduced those icons.  I had img
> src="/images..." which should have been img src="${rootUrl}/images..."
>
> %-|
> --
> View this message in context: http://www.nabble.com/emma-plugin-icons-tf4135060.html#a11764993
> Sent from the Hudson users mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: emma plugin icons

Kohsuke Kawaguchi
Administrator
In reply to this post by Arnaud LACOUR
Arnaud LACOUR wrote:
> I have problems since this morning with the emma plugin, it is not
> generating the trend graph at all and there's not much output to help
> in that department in the console output, could there be a debug
> checkbox on the plugin config page to allow easier investigation on
> live systems when sh17 hits the fan ?

The usual approach for debug probes is to define "public static boolean
debug=false;" in the code and then allow people to activate it by the
scripting console.

I'm really trying to keep the # of configurations smaller, and I don't
think debug option is worth the real estate.

If it's necessary to make this little more discoverable, we can define a
page that lists all such debug switches. I just need to define an
annotation to be placed on the debug switch, then tweak maven-hpi-plugin
a bit to allow the runtime to list them all.

--
Kohsuke Kawaguchi
Sun Microsystems                   [hidden email]

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: emma plugin icons

Arnaud LACOUR
sounds reasonable ...

On 7/24/07, Kohsuke Kawaguchi <[hidden email]> wrote:

> Arnaud LACOUR wrote:
> > I have problems since this morning with the emma plugin, it is not
> > generating the trend graph at all and there's not much output to help
> > in that department in the console output, could there be a debug
> > checkbox on the plugin config page to allow easier investigation on
> > live systems when sh17 hits the fan ?
>
> The usual approach for debug probes is to define "public static boolean
> debug=false;" in the code and then allow people to activate it by the
> scripting console.
>
> I'm really trying to keep the # of configurations smaller, and I don't
> think debug option is worth the real estate.
>
> If it's necessary to make this little more discoverable, we can define a
> page that lists all such debug switches. I just need to define an
> annotation to be placed on the debug switch, then tweak maven-hpi-plugin
> a bit to allow the runtime to list them all.
>
> --
> Kohsuke Kawaguchi
> Sun Microsystems                   [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]