failed authentication-filter

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

failed authentication-filter

GBossert
Hello,
i'm working on aplugin but since i've decided to re-install my environnement of dev,
i'm facing with this message on mvn hpi:run

failed authentication-filter
groovy.lang.MissingPropertyException: No such property: authenticationManagerProxy for class: hudson.util.spring.BeanBuilder

and when i try to acces to the web gui i have a 503 error.

- I think it comes from my plugin and not the environnement because i've downloaded tack and warning sources and they work fine.
- This message first appears when i worked on my "pom" file. i've changed it to make it fit to my needs :

-POM----------------------------------------------------------
<project xmlns="http://maven.apache.org/POM/4.0.0"
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>   
    <parent>
        <groupId>org.jvnet.hudson.plugins</groupId>
        <artifactId>plugin</artifactId>
        <version>1.226</version>
        <relativePath>../pom.xml</relativePath>
    </parent>   
    <groupId>com.serenitec</groupId>
    <packaging>hpi</packaging>
    <artifactId>hudsonPlugin</artifactId>
    <name>Hudson Serenitec Plugin.</name>
    <version>0.12-SNAPSHOT</version>
    <description>Execute the Serenitec refactoring solution on your project and
    generate reports of its activities.</description>
   
    <licenses>
        <license>
          <name>BSD Style</name>
          <comments>All source code is under the BSD license.</comments>
        </license>
    </licenses>   
   
    <dependencies>
        <dependency>
          <groupId>de.java2html</groupId>
          <artifactId>java2html</artifactId>
          <version>5.0</version>
        </dependency>
        <dependency>
          <groupId>commons-lang</groupId>
          <artifactId>commons-lang</artifactId>
          <version>2.3</version>
        </dependency>
        <dependency>
          <groupId>findbugs</groupId>
          <artifactId>annotations</artifactId>
          <version>1.0.0</version>
        </dependency>
        <dependency>
          <groupId>junit</groupId>
          <artifactId>junit</artifactId>
          <version>4.3.1</version>
          <scope>test</scope>
        </dependency>
        <dependency>
          <groupId>org.easymock</groupId>
          <artifactId>easymock</artifactId>
          <version>2.3</version>
          <scope>test</scope>
        </dependency>
        <dependency>
          <groupId>org.easymock</groupId>
          <artifactId>easymockclassextension</artifactId>
          <version>2.3</version>
          <scope>test</scope>
        </dependency>
        <dependency>
          <groupId>org.jvnet.localizer</groupId>
          <artifactId>localizer</artifactId>
          <version>1.5</version>
        </dependency>
  </dependencies>
   
  <build>
    <plugins>
      <plugin>
        <groupId>org.kohsuke.stapler</groupId>
        <artifactId>maven-stapler-plugin</artifactId>
        <extensions>true</extensions>
      </plugin>
      <plugin>
        <groupId>org.jvnet.hudson.tools</groupId>
        <artifactId>maven-hpi-plugin</artifactId>
        <configuration>
          <showDeprecation>true</showDeprecation>
          <showWarnings>true</showWarnings>
        </configuration>
      </plugin>
    </plugins>
  </build> 
 
  <repositories>
    <repository>
      <id>java.net2</id>
      <url>http://download.java.net/maven/2/</url>
      <releases>
        <enabled>true</enabled>
        <updatePolicy>never</updatePolicy>
      </releases>
      <snapshots>
        <enabled>false</enabled>
      </snapshots>
    </repository>
  </repositories>

  <reporting>
    <plugins>
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-pmd-plugin</artifactId>
        <version>4.3</version>
        <configuration>
          <rulesets>
            <ruleset>${project.artifactId}/.ruleset</ruleset>
          </rulesets>
          <targetJdk>1.5</targetJdk>
        </configuration>
      </plugin>
      <plugin>
        <groupId>org.codehaus.mojo</groupId>
        <artifactId>findbugs-maven-plugin</artifactId>
        <version>1.2</version>
        <configuration>
          <xmlOutput>true</xmlOutput>
          <findbugsXmlOutput>true</findbugsXmlOutput>
          <findbugsXmlWithMessages>true</findbugsXmlWithMessages>
          <threshold>Low</threshold>
          <effort>Max</effort>
          <debug>false</debug>
          <relaxed>false</relaxed>
        </configuration>
      </plugin>
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-checkstyle-plugin</artifactId>
        <version>2.1</version>
        <configuration>
          <configLocation>${project.artifactId}/checkstyle-configuration.xml
          </configLocation>
        </configuration>
      </plugin>
    </plugins>
  </reporting>   
</project>
-POM----------------------------------------------------------

But i've compared it to differents plugins and really don't catch errors.



Reply | Threaded
Open this post in threaded view
|

Re: failed authentication-filter

Kohsuke Kawaguchi
Administrator
gboss wrote:
> Hello,
> i'm working on aplugin but since i've decided to re-install my environnement
> of dev,
> i'm facing with this message on mvn hpi:run

Cool! Would you be interested in hosting the plugin in Hudson Subversion
repository?


I'd suggest "mvn clean" or wipe out all the generated files in your
workspace. The error message suggests that your Hudson core version and
Hudson war contents are out of sync somehow.

> failed authentication-filter
> groovy.lang.MissingPropertyException: No such property:
> authenticationManagerProxy for class: hudson.util.spring.BeanBuilder
>
> and when i try to acces to the web gui i have a 503 error.
>
> - I think it comes from my plugin and not the environnement because i've
> downloaded tack and warning sources and they work fine.
> - This message first appears when i worked on my "pom" file. i've changed it
> to make it fit to my needs :
>
> -POM----------------------------------------------------------
> <project xmlns="http://maven.apache.org/POM/4.0.0"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
> http://maven.apache.org/xsd/maven-4.0.0.xsd">
>     <modelVersion>4.0.0</modelVersion>    
>     <parent>
>         <groupId>org.jvnet.hudson.plugins</groupId>
>         <artifactId>plugin</artifactId>
>         <version>1.226</version>
>         <relativePath>../pom.xml</relativePath>
>     </parent>    
>     <groupId>com.serenitec</groupId>
>     <packaging>hpi</packaging>
>     <artifactId>hudsonPlugin</artifactId>
>     <name>Hudson Serenitec Plugin.</name>
>     <version>0.12-SNAPSHOT</version>
>     <description>Execute the Serenitec refactoring solution on your project
> and
>     generate reports of its activities.</description>
>    
>     <licenses>
>         <license>
>           <name>BSD Style</name>
>           <comments>All source code is under the BSD license.</comments>
>         </license>
>     </licenses>    
>    
>     <dependencies>
>         <dependency>
>           <groupId>de.java2html</groupId>
>           <artifactId>java2html</artifactId>
>           <version>5.0</version>
>         </dependency>
>         <dependency>
>           <groupId>commons-lang</groupId>
>           <artifactId>commons-lang</artifactId>
>           <version>2.3</version>
>         </dependency>
>         <dependency>
>           <groupId>findbugs</groupId>
>           <artifactId>annotations</artifactId>
>           <version>1.0.0</version>
>         </dependency>
>         <dependency>
>           <groupId>junit</groupId>
>           <artifactId>junit</artifactId>
>           <version>4.3.1</version>
>           <scope>test</scope>
>         </dependency>
>         <dependency>
>           <groupId>org.easymock</groupId>
>           <artifactId>easymock</artifactId>
>           <version>2.3</version>
>           <scope>test</scope>
>         </dependency>
>         <dependency>
>           <groupId>org.easymock</groupId>
>           <artifactId>easymockclassextension</artifactId>
>           <version>2.3</version>
>           <scope>test</scope>
>         </dependency>
>         <dependency>
>           <groupId>org.jvnet.localizer</groupId>
>           <artifactId>localizer</artifactId>
>           <version>1.5</version>
>         </dependency>
>   </dependencies>
>    
>   <build>
>     <plugins>
>       <plugin>
>         <groupId>org.kohsuke.stapler</groupId>
>         <artifactId>maven-stapler-plugin</artifactId>
>         <extensions>true</extensions>
>       </plugin>
>       <plugin>
>         <groupId>org.jvnet.hudson.tools</groupId>
>         <artifactId>maven-hpi-plugin</artifactId>
>         <configuration>
>           <showDeprecation>true</showDeprecation>
>           <showWarnings>true</showWarnings>
>         </configuration>
>       </plugin>
>     </plugins>
>   </build>  
>  
>   <repositories>
>     <repository>
>       <id>java.net2</id>
>       <url>http://download.java.net/maven/2/</url>
>       <releases>
>         <enabled>true</enabled>
>         <updatePolicy>never</updatePolicy>
>       </releases>
>       <snapshots>
>         <enabled>false</enabled>
>       </snapshots>
>     </repository>
>   </repositories>
>
>   <reporting>
>     <plugins>
>       <plugin>
>         <groupId>org.apache.maven.plugins</groupId>
>         <artifactId>maven-pmd-plugin</artifactId>
>         <version>4.3</version>
>         <configuration>
>           <rulesets>
>             <ruleset>${project.artifactId}/.ruleset</ruleset>
>           </rulesets>
>           <targetJdk>1.5</targetJdk>
>         </configuration>
>       </plugin>
>       <plugin>
>         <groupId>org.codehaus.mojo</groupId>
>         <artifactId>findbugs-maven-plugin</artifactId>
>         <version>1.2</version>
>         <configuration>
>           <xmlOutput>true</xmlOutput>
>           <findbugsXmlOutput>true</findbugsXmlOutput>
>           <findbugsXmlWithMessages>true</findbugsXmlWithMessages>
>           <threshold>Low</threshold>
>           <effort>Max</effort>
>           <debug>false</debug>
>           <relaxed>false</relaxed>
>         </configuration>
>       </plugin>
>       <plugin>
>         <groupId>org.apache.maven.plugins</groupId>
>         <artifactId>maven-checkstyle-plugin</artifactId>
>         <version>2.1</version>
>         <configuration>
>           <configLocation>${project.artifactId}/checkstyle-configuration.xml
>           </configLocation>
>         </configuration>
>       </plugin>
>     </plugins>
>   </reporting>    
> </project>
> -POM----------------------------------------------------------
>
> But i've compared it to differents plugins and really don't catch errors.
>
>
>
>

--
Kohsuke Kawaguchi
Sun Microsystems                   http://weblogs.java.net/blog/kohsuke/

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: failed authentication-filter

GBossert
You were right, i've re-synchro my project with the env. and it's allright.
Thank you !

kohsuke wrote
gboss wrote:
> Hello,
> i'm working on aplugin but since i've decided to re-install my environnement
> of dev,
> i'm facing with this message on mvn hpi:run

Cool! Would you be interested in hosting the plugin in Hudson Subversion
repository?


I'd suggest "mvn clean" or wipe out all the generated files in your
workspace. The error message suggests that your Hudson core version and
Hudson war contents are out of sync somehow.

> failed authentication-filter
> groovy.lang.MissingPropertyException: No such property:
> authenticationManagerProxy for class: hudson.util.spring.BeanBuilder
>
> and when i try to acces to the web gui i have a 503 error.
>
> - I think it comes from my plugin and not the environnement because i've
> downloaded tack and warning sources and they work fine.
> - This message first appears when i worked on my "pom" file. i've changed it
> to make it fit to my needs :
>
> -POM----------------------------------------------------------
> <project xmlns="http://maven.apache.org/POM/4.0.0"
>  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
> http://maven.apache.org/xsd/maven-4.0.0.xsd">
>     <modelVersion>4.0.0</modelVersion>   
>     <parent>
>         <groupId>org.jvnet.hudson.plugins</groupId>
>         <artifactId>plugin</artifactId>
>         <version>1.226</version>
>         <relativePath>../pom.xml</relativePath>
>     </parent>   
>     <groupId>com.serenitec</groupId>
>     <packaging>hpi</packaging>
>     <artifactId>hudsonPlugin</artifactId>
>     <name>Hudson Serenitec Plugin.</name>
>     <version>0.12-SNAPSHOT</version>
>     <description>Execute the Serenitec refactoring solution on your project
> and
>     generate reports of its activities.</description>
>    
>     <licenses>
>         <license>
>           <name>BSD Style</name>
>           <comments>All source code is under the BSD license.</comments>
>         </license>
>     </licenses>   
>    
>     <dependencies>
>         <dependency>
>           <groupId>de.java2html</groupId>
>           <artifactId>java2html</artifactId>
>           <version>5.0</version>
>         </dependency>
>         <dependency>
>           <groupId>commons-lang</groupId>
>           <artifactId>commons-lang</artifactId>
>           <version>2.3</version>
>         </dependency>
>         <dependency>
>           <groupId>findbugs</groupId>
>           <artifactId>annotations</artifactId>
>           <version>1.0.0</version>
>         </dependency>
>         <dependency>
>           <groupId>junit</groupId>
>           <artifactId>junit</artifactId>
>           <version>4.3.1</version>
>           <scope>test</scope>
>         </dependency>
>         <dependency>
>           <groupId>org.easymock</groupId>
>           <artifactId>easymock</artifactId>
>           <version>2.3</version>
>           <scope>test</scope>
>         </dependency>
>         <dependency>
>           <groupId>org.easymock</groupId>
>           <artifactId>easymockclassextension</artifactId>
>           <version>2.3</version>
>           <scope>test</scope>
>         </dependency>
>         <dependency>
>           <groupId>org.jvnet.localizer</groupId>
>           <artifactId>localizer</artifactId>
>           <version>1.5</version>
>         </dependency>
>   </dependencies>
>    
>   <build>
>     <plugins>
>       <plugin>
>         <groupId>org.kohsuke.stapler</groupId>
>         <artifactId>maven-stapler-plugin</artifactId>
>         <extensions>true</extensions>
>       </plugin>
>       <plugin>
>         <groupId>org.jvnet.hudson.tools</groupId>
>         <artifactId>maven-hpi-plugin</artifactId>
>         <configuration>
>           <showDeprecation>true</showDeprecation>
>           <showWarnings>true</showWarnings>
>         </configuration>
>       </plugin>
>     </plugins>
>   </build> 
>  
>   <repositories>
>     <repository>
>       <id>java.net2</id>
>       <url>http://download.java.net/maven/2/</url>
>       <releases>
>         <enabled>true</enabled>
>         <updatePolicy>never</updatePolicy>
>       </releases>
>       <snapshots>
>         <enabled>false</enabled>
>       </snapshots>
>     </repository>
>   </repositories>
>
>   <reporting>
>     <plugins>
>       <plugin>
>         <groupId>org.apache.maven.plugins</groupId>
>         <artifactId>maven-pmd-plugin</artifactId>
>         <version>4.3</version>
>         <configuration>
>           <rulesets>
>             <ruleset>${project.artifactId}/.ruleset</ruleset>
>           </rulesets>
>           <targetJdk>1.5</targetJdk>
>         </configuration>
>       </plugin>
>       <plugin>
>         <groupId>org.codehaus.mojo</groupId>
>         <artifactId>findbugs-maven-plugin</artifactId>
>         <version>1.2</version>
>         <configuration>
>           <xmlOutput>true</xmlOutput>
>           <findbugsXmlOutput>true</findbugsXmlOutput>
>           <findbugsXmlWithMessages>true</findbugsXmlWithMessages>
>           <threshold>Low</threshold>
>           <effort>Max</effort>
>           <debug>false</debug>
>           <relaxed>false</relaxed>
>         </configuration>
>       </plugin>
>       <plugin>
>         <groupId>org.apache.maven.plugins</groupId>
>         <artifactId>maven-checkstyle-plugin</artifactId>
>         <version>2.1</version>
>         <configuration>
>           <configLocation>${project.artifactId}/checkstyle-configuration.xml
>           </configLocation>
>         </configuration>
>       </plugin>
>     </plugins>
>   </reporting>   
> </project>
> -POM----------------------------------------------------------
>
> But i've compared it to differents plugins and really don't catch errors.
>
>
>
>


--
Kohsuke Kawaguchi
Sun Microsystems                   http://weblogs.java.net/blog/kohsuke/