jenkins pipeline scripts are blank in the UI after upgrade

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

jenkins pipeline scripts are blank in the UI after upgrade

Konstantinos Christidis
Hi all,

I have upgraded Jenkins from 2.176 to 2.190.1 as well as the suggested plugins (the ones without dependencies) and I am facing the following issue.

I am creating a Pipeline script and I am saving the job. Afterwards I am opening the same job and the Pipeline script is empty in the UI.

If I don't Save/Apply the empty job I can see the 'Hello World' log in the Console output when running the job.
If I save the empty Pipeline script then it is completely lost..

https://i.paste.pics/70EV5.png

I had to revert Jenkins back to 2.176 (from a backup) as this was affecting all my jobs.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/CAD6gr7KgkE_0joKsgOXoPjL-TRpJ7PhrjrZ46JG0wk32DzajAQ%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: jenkins pipeline scripts are blank in the UI after upgrade

Mark Waite-2
Can you explain what you mean by "the ones without dependencies"?  I would guess you mean that you updated some of the plugins when you switched to the new release, but did not update all of the plugins.  If so, then you may have detected an incomplete or incorrect definition of dependencies between plugins.

Before you reverted back to 2.176, did you try updating all the plugins, instead of just the "ones without dependencies"?

On Thu, Oct 17, 2019 at 11:22 AM Konstantinos Christidis <[hidden email]> wrote:
Hi all,

I have upgraded Jenkins from 2.176 to 2.190.1 as well as the suggested plugins (the ones without dependencies) and I am facing the following issue.

I am creating a Pipeline script and I am saving the job. Afterwards I am opening the same job and the Pipeline script is empty in the UI.

If I don't Save/Apply the empty job I can see the 'Hello World' log in the Console output when running the job.
If I save the empty Pipeline script then it is completely lost..

https://i.paste.pics/70EV5.png

I had to revert Jenkins back to 2.176 (from a backup) as this was affecting all my jobs.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/CAD6gr7KgkE_0joKsgOXoPjL-TRpJ7PhrjrZ46JG0wk32DzajAQ%40mail.gmail.com.


--
Thanks!
Mark Waite

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/CAO49JtFZcnCMrqh1ekduW%3D1bSu0Pz4%3DS%3DyHWYuzRm-xGvxwp_g%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: jenkins pipeline scripts are blank in the UI after upgrade

Konstantinos Christidis
Right, I have only updated the suggested plugins, the ones that were marked eligible for update.
No I didn't try updating then all before reverting back.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/9c810638-dea7-44ca-985e-90fc2a1f0ff2%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: jenkins pipeline scripts are blank in the UI after upgrade

Konstantinos Christidis
In reply to this post by Konstantinos Christidis
I've just updated Jenkins again from from 2.176 to 2.190.1, this time I didn't update the plugins and the issue didn't come up.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/dcb4f281-1798-4eeb-a096-07397937161d%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: jenkins pipeline scripts are blank in the UI after upgrade

Konstantinos Christidis
In reply to this post by Konstantinos Christidis
The same issue has been reported here:

The solution was to skip upgrading the "Prometheus metrics" plugin.
If you have already updated the plugin, then downgrade it and restart JS.

On Thursday, October 17, 2019 at 8:22:26 PM UTC+3, kochrist wrote:
Hi all,

I have upgraded Jenkins from 2.176 to 2.190.1 as well as the suggested plugins (the ones without dependencies) and I am facing the following issue.

I am creating a Pipeline script and I am saving the job. Afterwards I am opening the same job and the Pipeline script is empty in the UI.

If I don't Save/Apply the empty job I can see the 'Hello World' log in the Console output when running the job.
If I save the empty Pipeline script then it is completely lost..

<a href="https://i.paste.pics/70EV5.png" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fi.paste.pics%2F70EV5.png\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEfg4_ygedgbeAfTYurUD7jiQpSrw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fi.paste.pics%2F70EV5.png\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEfg4_ygedgbeAfTYurUD7jiQpSrw&#39;;return true;">https://i.paste.pics/70EV5.png

I had to revert Jenkins back to 2.176 (from a backup) as this was affecting all my jobs.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/3dc42993-4eb8-437b-9df2-2fffce6761de%40googlegroups.com.