jenkins slave run in jdk 1.6

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

jenkins slave run in jdk 1.6

miyapuram...@gmail.com
Hi All,

i have a very complex environment in my jenkins build and deployment. There are four kinds of system: windows(for the jboss java environment), aix(for the xlc compiler), linux(for the websphere jee application), mac (for the ios development). Different system own their jdk, the least one is the JDK 1.6. For the AIX IBM JDK(with the DES SDK problem), so i need the jenkins 2.32.1+, but my environment which has the JDK 1.6, so the slave JNLP showing error it requries JDK8 . But the jenkins slave jar need the JDK 1.7+, so i thinks weather i can compile the slave jar by myself for the jdk 1.6.

How can i solve this problem?


Pls help on this.


Regards,

M.Venkat.

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/633cc212-b2e0-4c5f-b45d-66a6be26d455n%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: jenkins slave run in jdk 1.6

Matt Sicker
This is the developer list for discussing development of Jenkins and
plugins. You want to try the jenkinsci-users mailing list or similar
chats: https://www.jenkins.io/mailing-lists/

On Thu, Jul 23, 2020 at 8:15 AM [hidden email]
<[hidden email]> wrote:

>
> Hi All,
>
> i have a very complex environment in my jenkins build and deployment. There are four kinds of system: windows(for the jboss java environment), aix(for the xlc compiler), linux(for the websphere jee application), mac (for the ios development). Different system own their jdk, the least one is the JDK 1.6. For the AIX IBM JDK(with the DES SDK problem), so i need the jenkins 2.32.1+, but my environment which has the JDK 1.6, so the slave JNLP showing error it requries JDK8 . But the jenkins slave jar need the JDK 1.7+, so i thinks weather i can compile the slave jar by myself for the jdk 1.6.
>
> How can i solve this problem?
>
>
> Pls help on this.
>
>
> Regards,
>
> M.Venkat.
>
> --
> You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
> To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/633cc212-b2e0-4c5f-b45d-66a6be26d455n%40googlegroups.com.



--
Matt Sicker
Senior Software Engineer, CloudBees

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/CAEot4oyQ%2BZagtNOktczZo6K%3DbepiFc4FK45fv2xSjUhzdwUB9w%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: jenkins slave run in jdk 1.6

Oleg Nenashev
Well, building a custom agent JAR version defintely belongs to the developer mailing list...

Regarding the question, no it is NOT possible to build the current agent.jar (Remoting) version for JDK 1.6. The code has moved on and adopted many features from newer Java versions, Java 1.8 is the minimum supported version. Good news is that you should not need to rebuild it at all. You can use Java 1.8 for running the Jenkins agent, but use older Java versions for running your software builds. FTR it is possible only for Freestyle and Pipeline projects, but not the Maven ones. 




On Thursday, July 23, 2020 at 5:09:51 PM UTC+2, Matt Sicker wrote:
This is the developer list for discussing development of Jenkins and
plugins. You want to try the jenkinsci-users mailing list or similar
chats: <a href="https://www.jenkins.io/mailing-lists/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.jenkins.io%2Fmailing-lists%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEOTYO7fZM5xqAThUyz8tsnyWyE6Q&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.jenkins.io%2Fmailing-lists%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEOTYO7fZM5xqAThUyz8tsnyWyE6Q&#39;;return true;">https://www.jenkins.io/mailing-lists/

On Thu, Jul 23, 2020 at 8:15 AM [hidden email]
<<a href="javascript:" target="_blank" gdf-obfuscated-mailto="E6ofy_KfCAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">miyapuram...@...> wrote:

>
> Hi All,
>
> i have a very complex environment in my jenkins build and deployment. There are four kinds of system: windows(for the jboss java environment), aix(for the xlc compiler), linux(for the websphere jee application), mac (for the ios development). Different system own their jdk, the least one is the JDK 1.6. For the AIX IBM JDK(with the DES SDK problem), so i need the jenkins 2.32.1+, but my environment which has the JDK 1.6, so the slave JNLP showing error it requries JDK8 . But the jenkins slave jar need the JDK 1.7+, so i thinks weather i can compile the slave jar by myself for the jdk 1.6.
>
> How can i solve this problem?
>
>
> Pls help on this.
>
>
> Regards,
>
> M.Venkat.
>
> --
> You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="E6ofy_KfCAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">jenkin...@googlegroups.com.
> To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/jenkinsci-dev/633cc212-b2e0-4c5f-b45d-66a6be26d455n%40googlegroups.com" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/jenkinsci-dev/633cc212-b2e0-4c5f-b45d-66a6be26d455n%40googlegroups.com&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/jenkinsci-dev/633cc212-b2e0-4c5f-b45d-66a6be26d455n%40googlegroups.com&#39;;return true;">https://groups.google.com/d/msgid/jenkinsci-dev/633cc212-b2e0-4c5f-b45d-66a6be26d455n%40googlegroups.com.



--
Matt Sicker
Senior Software Engineer, CloudBees

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/d70cba58-982c-49db-8c72-f1b20f02c40bo%40googlegroups.com.