problem with AJP13 and apache

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

problem with AJP13 and apache

Johannes Eickhold
Hi,

I'm trying to hide hudson behind an apache2 but can't get the connection
between them to work. Mabe anybody here can give me a hand? I guess my
fault is in the apache configuration part
(/etc/apache2/workers2.properties).

What I did:
- start hudson via "java -jar hudson_1.101.war --httpPort=-1
--ajp13ListenAddress=localhost"
- from the log I see:
"[Winstone 2007/04/16 23:55:40] - AJP13 Listener started: port=8009"
- netstat confirms
tcp6       0      0 ::ffff:127.0.0.1:8009   :::*
LISTEN     11990/java
- call the URL "https://myhost/hudson/" and get a 404 error from
Winstone:
"
Status Code: 404
Exception:
Stacktrace:
(none)
Generated by Winstone Servlet Engine v0.9.6 at Mon Apr 16 23:59:58 CEST
2007
"

My apache is configured to only use SSL.

See my workers2.properties and hudson log attached.

Thanks,
  Johannes.

PS: My system is Debian sarge with the relevant packages:
apache2 2.0.55-4.1
libapache2-mod-jk2 2.0.4-3


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

workers2.properties (420 bytes) Download Attachment
hudson.log (665 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: problem with AJP13 and apache

Kohsuke Kawaguchi
Administrator

The way HTTP works requires that you use the same context path in Apache
and Winstone.

So I think you need:

   --prefix=hudson

so that Winstone responds to /hudson/... URLs.


Johannes Eickhold wrote:

> Hi,
>
> I'm trying to hide hudson behind an apache2 but can't get the connection
> between them to work. Mabe anybody here can give me a hand? I guess my
> fault is in the apache configuration part
> (/etc/apache2/workers2.properties).
>
> What I did:
> - start hudson via "java -jar hudson_1.101.war --httpPort=-1
> --ajp13ListenAddress=localhost"
> - from the log I see:
> "[Winstone 2007/04/16 23:55:40] - AJP13 Listener started: port=8009"
> - netstat confirms
> tcp6       0      0 ::ffff:127.0.0.1:8009   :::*
> LISTEN     11990/java
> - call the URL "https://myhost/hudson/" and get a 404 error from
> Winstone:
> "
> Status Code: 404
> Exception:
> Stacktrace:
> (none)
> Generated by Winstone Servlet Engine v0.9.6 at Mon Apr 16 23:59:58 CEST
> 2007
> "
>
> My apache is configured to only use SSL.
>
> See my workers2.properties and hudson log attached.
>
> Thanks,
>   Johannes.
>
> PS: My system is Debian sarge with the relevant packages:
> apache2 2.0.55-4.1
> libapache2-mod-jk2 2.0.4-3
>
>
>
> ------------------------------------------------------------------------
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]

--
Kohsuke Kawaguchi
Sun Microsystems                   [hidden email]

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: problem with AJP13 and apache

Johannes Eickhold
On Mon, 2007-04-16 at 16:52 -0700, Kohsuke Kawaguchi wrote:
> The way HTTP works requires that you use the same context path in Apache
> and Winstone.
>
> So I think you need:
>
>    --prefix=hudson
>
> so that Winstone responds to /hudson/... URLs.

Jep. That fixed it!

Thank you,
  Johannes.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]