regarding issues publishing new plugin, but publishing works when publishing a snapshot

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

regarding issues publishing new plugin, but publishing works when publishing a snapshot

john rowley

Hello,

 

I recently went through the process of developing a Jenkins plugin, getting it hosted, getting permissions for publishing to artifactory, etc. Everything was working correctly until I attempted to release the plugin.

 

I was able to release a snapshot of the plugin, and this worked fine. The artifacts appear to all have been uploaded successfully, to the following URL. https://repo.jenkins-ci.org/snapshots/io/jenkins/plugins/bitbucket-kubernetes-credentials/0.0.1-SNAPSHOT/ Upon bumping and attempting to release the plugin I encountered 403 errors from artifactory.

 

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.8.2:deploy (default-deploy) on project bitbucket-kubernetes-credentials: Failed to deploy artifacts: Could not transfer artifact io.jenkins.plugins:bitbucket-kubernetes-credentials:hpi:0.0.3 from/to maven.jenkins-ci.org (https://repo.jenkins-ci.org/releases/): Authorization failed for https://repo.jenkins-ci.org/releases/io/jenkins/plugins/bitbucket-kubernetes-credentials/0.0.3/bitbucket-kubernetes-credentials-0.0.3.hpi 403 Forbidden -> [Help 1]

 

I did create a pull request and get permissions to release this plugin several hours ago, and I believe that the yaml for the repository-permissions-updater  is correct, firstly because it was looked over during the PR, secondly because I was able to upload to the snapshots path, but not the releases path. https://github.com/robbert229/repository-permissions-updater/blob/master/permissions/plugin-bitbucket-kubernetes-credentials.yml

 

What are the steps I should take to begin debugging this, and what could I possibly have done wrong?

 

Thank you


--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/415bea83-484c-4d77-8526-8bf278b0e646%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: regarding issues publishing new plugin, but publishing works when publishing a snapshot

slide
According to https://www.jenkins.io/doc/developer/publishing/releasing/ 403 means the permissions are not setup. It's possible you just need to wait a little bit and try again.

On Fri, May 22, 2020, 18:15 john rowley <[hidden email]> wrote:

Hello,

 

I recently went through the process of developing a Jenkins plugin, getting it hosted, getting permissions for publishing to artifactory, etc. Everything was working correctly until I attempted to release the plugin.

 

I was able to release a snapshot of the plugin, and this worked fine. The artifacts appear to all have been uploaded successfully, to the following URL. https://repo.jenkins-ci.org/snapshots/io/jenkins/plugins/bitbucket-kubernetes-credentials/0.0.1-SNAPSHOT/ Upon bumping and attempting to release the plugin I encountered 403 errors from artifactory.

 

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.8.2:deploy (default-deploy) on project bitbucket-kubernetes-credentials: Failed to deploy artifacts: Could not transfer artifact io.jenkins.plugins:bitbucket-kubernetes-credentials:hpi:0.0.3 from/to maven.jenkins-ci.org (https://repo.jenkins-ci.org/releases/): Authorization failed for https://repo.jenkins-ci.org/releases/io/jenkins/plugins/bitbucket-kubernetes-credentials/0.0.3/bitbucket-kubernetes-credentials-0.0.3.hpi 403 Forbidden -> [Help 1]

 

I did create a pull request and get permissions to release this plugin several hours ago, and I believe that the yaml for the repository-permissions-updater  is correct, firstly because it was looked over during the PR, secondly because I was able to upload to the snapshots path, but not the releases path. https://github.com/robbert229/repository-permissions-updater/blob/master/permissions/plugin-bitbucket-kubernetes-credentials.yml

 

What are the steps I should take to begin debugging this, and what could I possibly have done wrong?

 

Thank you


--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/415bea83-484c-4d77-8526-8bf278b0e646%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/CAPiUgVfnC-SV60TTnjzEAmVYx9j%3D9h5Z9-gMyYOzD4oEORujtg%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: regarding issues publishing new plugin, but publishing works when publishing a snapshot

Daniel Beck
In reply to this post by john rowley
io/jenkins/plugin
io/jenkins/plugins


> On 23. May 2020, at 02:26, john rowley <[hidden email]> wrote:
>
>  

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/D9BBE4D1-2C1E-4290-B046-E5EB37C48793%40beckweb.net.