warning about deprecated protocols

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

warning about deprecated protocols

masaru tsuchiyama
Hello

The recent version of Jenkin shows the following warning.
But I don't know how to disable the deprecated protocols.

This Jenkins instance uses deprecated protocols:
JNLP-connect,JNLP2-connect. It may impact stability of the instance. If
newer protocol versions are supported by all system components (agents,
CLI and other clients), it is highly recommended to disable the
deprecated protocols.

Does anyone know that?

--
Masaru Tsuchiyama <[hidden email]>

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/fe40be9a-e8e4-0a5a-e20d-0b96dc0581f9%40gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: warning about deprecated protocols

Daniel Beck

> On 9. Sep 2017, at 01:39, Masaru Tsuchiyama <[hidden email]> wrote:
>
> This Jenkins instance uses deprecated protocols: JNLP-connect,JNLP2-connect. It may impact stability of the instance. If newer protocol versions are supported by all system components (agents, CLI and other clients), it is highly recommended to disable the deprecated protocols.

https://yourjenkins/configureSecurity URL, near the top, hidden behind an 'Advanced' type button.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/B90F2C83-D6ED-4025-9988-FE10F0A10E16%40beckweb.net.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: warning about deprecated protocols

masaru tsuchiyama
Hello

Thank you for the replay.
But I couldn't find 'Advanced' type button.

Could you tell me where it is?

I attached the screenshots of the URL.

Regards.


Daniel Beck wrote:
>
>> On 9. Sep 2017, at 01:39, Masaru Tsuchiyama <[hidden email]> wrote:
>>
>> This Jenkins instance uses deprecated protocols: JNLP-connect,JNLP2-connect. It may impact stability of the instance. If newer protocol versions are supported by all system components (agents, CLI and other clients), it is highly recommended to disable the deprecated protocols.
>
> https://yourjenkins/configureSecurity URL, near the top, hidden behind an 'Advanced' type button.
>

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/ba4d2071-3981-5591-72ac-87a0e0986e0b%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

jenkins.png (304K) Download Attachment
jenkins2.png (194K) Download Attachment
jenkins3.png (185K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: warning about deprecated protocols

Daniel Beck

> On 9. Sep 2017, at 06:04, Masaru Tsuchiyama <[hidden email]> wrote:
>
> Could you tell me where it is?

Labeled 'Agent protocols…'.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/45B6CC6A-29B0-4062-BF63-87A6B7977F54%40beckweb.net.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: warning about deprecated protocols

masaru tsuchiyama
Hello

Thank you for the answer.

I was able to disable the deprecated protocols successfuly.
The warning disappeared.

I think the warning should mention that users need to press
'Agent Protocols...' button to do that.

Daniel Beck wrote:
>
>> On 9. Sep 2017, at 06:04, Masaru Tsuchiyama <[hidden email]> wrote:
>>
>> Could you tell me where it is?
>
> Labeled 'Agent protocols…'.
>


--
Masaru Tsuchiyama <[hidden email]>

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/15ac52ea-bd6c-c285-cb77-2d7125ce3059%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

jenkins4.png (188K) Download Attachment
jenkins5.png (254K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: warning about deprecated protocols

Oleg Nenashev
In reply to this post by Daniel Beck
I have created JENKINS-46760 and https://github.com/jenkinsci/jenkins/pull/3012 to disable this administrative monitor when the TCP Agent Listener is disabled. As Daniel pointed out above, in the current instance the protocols should be just disabled in Web UI.

суббота, 9 сентября 2017 г., 18:44:14 UTC+1 пользователь Daniel Beck написал:

> On 9. Sep 2017, at 06:04, Masaru Tsuchiyama <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="vvGcXBVhAgAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">m.tm...@...> wrote:
>
> Could you tell me where it is?

Labeled 'Agent protocols…'.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/1e9cf107-6e25-49b0-b601-337806bbe23b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.